Fiery Command WorkStation

The most intuitive print job management interface

Centralises job management, connects to all Fiery servers on the network and improves results for increased productivity. 

Free Download - Version 5.8


Client: Mac® OS
  • Processor: Multicore Intel® processor
  • Mac OS X® v 10.7, 10.8, 10.9, 10.10, and 10.11
  • To use Command WorkStation with client computers running Mac OS 10.6, please download Command WorkStation 5.7
  • 4 GB of RAM or more recommended
  • 7 GB of available hard drive space
  • 1024x768 display with 16-bit video card
  • To use Fiery® Image Enhance Visual Editor, install on a client with 20GB available hard drive space
  • Fiery JobMaster, Impose and Compose support use of Acrobat Professional version 8, 9, 10, 11, and 12

Client: Windows®
  • Processor: Pentium 4, 1 GHz or faster processor
  • Microsoft® Windows 10 (32 and 64-bit) Home, Pro and Enterprise
  • Microsoft® Windows 8 and 8.1 Edition, Windows 8 and 8.1 Pro Edition (32 and 64-bit)
  • Windows 7 (32 and 64-bit) Home Premium, Professional, Ultimate
  • Windows Server 2008 (32 and 64-bit) Standard Edition, Enterprise Edition, Datacenter Edition, Web Server, Itanium-based
  • Windows Server 2008 SP1 (64-bit), R2 (32 and 64-bit)
  • Windows Server 2012 (64-bit) Foundation Edition, Essentials Edition, Standard Edition, Datacenter Edition
  • Windows Vista (32 and 64-bit) Home Basic Edition, Home Premium Edition, Ultimate Edition, Business Edition, Enterprise Edition
  • To use Command WorkStation with client computers running Windows XP and Windows Server 2003, please download Command WorkStation 5.7
  • 1 GB or more of RAM
  • 16 GB of available hard drive space
  • 1024x768 display with 16-bit video card
  • To use Image Enhance Visual Editor, install on a client with 2GB RAM
  • Fiery JobMaster, Impose and Compose support use of Acrobat Standard and Professional version 7, 8, 9, 10, 11, and 12

Server: System 6 through 8 Release 2
Server: System 9 and above
  • Supports installation of Command WorkStation 5.8

Fiery Color Profiler Suite
Fiery Command WorkStation 5.8 supports Fiery Color Profiler Suite 4.5 and above. To upgrade Fiery Color Profiler Suite 3.x to the latest version contact your Fiery reseller. All users of Fiery Color Profiler Suite 4.x are entitled to upgrade to version 4.5. Contact profilersupport@efi.com for more information.

For more information on key feature support by Fiery system software version download the feature matrix datasheet listed in the Resources page