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When PrintSmith Vision Is EFI-Hosted 
When EFI hosts PrintSmith Vision for you, PrintSmith Vision is installed on a server in the EFI hosting center, not 
in your facility. This cloud-based option means that EFI takes care of the hardware and software infrastructure for 
you, as well as the installation of PrintSmith Vision, updates, backups, and so on.  

To run PrintSmith Vision, you just use a supported browser from any client computer that meets the 
requirements listed on page 7. 

About this Guide 
When PrintSmith Vision is EFI-hosted, some procedures described in other PrintSmith Vision guides (especially 
the PrintSmith Vision - Setup and User Guide) do not apply and others are slightly different.  

This guide explains what is different, but is not intended to be used instead of other guides; you will still need 
most of the information in the rest of the PrintSmith Vision documentation. 

This table summarizes what this guide covers: 

For Information About See Page 

Requirements for client computers, browsers, monitor, and so on 7 
Starting PrintSmith Vision and logging in 8 
What does not apply in EFI-hosted installations  9 
E-mail configuration in EFI-hosted installations 12 
Customizing documents and reports in EFI-hosted installations 12 
Fiery integration when PrintSmith Vision is EFI-hosted 27 
Printing receipts 29 
Managing your digital assets (content files) 31 
Network connectivity issues 39 

Additional Sources 
For information about See 

Setting up and using PrintSmith Vision PrintSmith Vision - Setup and User Guide 
Taking advantage of the Fiery integration PrintSmith Vision - Fiery Integration Guide 
Configuring and using integrated credit card processing 
in PrintSmith Vision 

PrintSmith Vision - Secure Credit Card Processing  

Setting up and using PrintSmith Vision Tracker PrintSmith Vision - Tracker User Guide 
Using PrintSmith Vision Scheduler PrintSmith Vision - Scheduler User Guide 
Using SugarCRM with PrintSmith Vision PrintSmith Vision - SugarCRM Integration Guide 
Using Digital StoreFront with PrintSmith Vision PrintSmith Vision - Digital StoreFront Integration 

Guide 
Using Four51 with PrintSmith Vision PrintSmith Vision - Four51 Integration Guide 
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Contact Information 
EFI Support 

Web Site: https://customer.efi.com/support 

US Phone: 1.855.EFI.4HLP 
480.538.5800 

UK Phone: +44 (0) 800.783.2737 

EU Phone: +49 (0) 2102.745.4500     

E-Mail: printsmith.support@efi.com 
 
Regular US Service Desk hours are 7 A.M. to 5 P.M. Mountain Standard Time, Monday – Friday 

Regular UK Service Desk hours are 8 A.M. to 5 P.M. Greenwich Mean Time, Monday – Friday 

Regular EU Service Desk hours are 9 A.M to 6 P.M. Central European Time, Monday – Friday   

Note For problems involving infrastructure (i.e., computers, networks, operating systems, backup software, 
printers, third-party software, etc.), contact the appropriate vendor. EFI cannot support these types of 
issues. 

EFI Professional Services 

US Phone: 651.365.5321 
US Fax: 651.365.5334 

US E-Mail: ProfessionalServicesOperations@efi.com 
Outside US E-Mail: EMEAProfessionalServicesOperations@efi.com 

 
EFI Professional Services can help you perform EFI software installations, upgrades, and updates. This group 
can also help you implement, customize, and optimize your EFI software, plus offers a range of training options. 

System Requirements 

Client computer 
These are the requirements for client computers from which you want to run PrintSmith Vision: 

Operating system: Windows 7, 8, or 10 
Macintosh OS X 10.8 or higher 

Memory: 4 GB minimum (more memory will improve performance) 

Browser  
The following browsers are supported for running PrintSmith Vision: 

• Mozilla Firefox® 50.x or later  

• Safari® 8.x or later (OS X 10.11) and Safari 10.x or later (OS X 10.12) 

• Chrome™ 54 or later 

• Microsoft Edge (Windows only) 

  

https://customer.efi.com/support
mailto:printsmith.support@efi.com
mailto:ProfessionalServicesOperations@efi.com
mailto:EMEAProfessionalServicesOperations@efi.com
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Monitor and resolution  
PrintSmith Vision is designed to be viewed and used on a large monitor with high resolution: 

• 19-inch monitor 

• Minimum resolution of 1280 x 1024  

Important If you are using a laptop, to see estimates and invoices in full, the height (second number) 
must be at least 1024 pixels.  

Custom documents and reports  
PrintSmith Vision reports and other documents (such as estimates or invoices) are written in i-net Clear Reports. 

If you want to customize your estimates or invoices (for example, include your logo) or if you plan to create 
custom reports, you must use i-net Designer. For information about installing i-net Designer and other required 
components for customizing reports, see “Customizing Documents and Reports” on page 12.  

Receipt printers  
A receipt printer is optional in PrintSmith Vision, but if you want to use one, you must purchase the Star TSP 
700ll printer from EFI. Remote Print Center (RPC) is also required – see below. 

Remote Print Center (RPC)  
RPC is required for Fiery integration and receipt printing. You can install one RPC per PrintSmith Vision server. 

The computer on which you install RPC must meet these hardware and software requirements: 

Operating system: Any 64-bit version of Windows or Macintosh OS X  
Processor: Dual core 

Memory: 4 GB  
Hard Drive: 50 – 100 GB 

 
In addition, the computer where you install RPC must: 

• For Fiery integration, have access to the Fiery device(s) you are using. 

• For receipt printing, be connected to the receipt printer. 

• Have access to the Internet, including access to PrintSmith Vision. 

• Run 24/7 and not go to sleep. It must be available for communication all the time. 

Tip On a Windows computer, turn off sleep mode in the Power Options settings in the Control Panel; on a 
Macintosh, turn off sleep mode in the Energy Saver settings. 

Logging Into PrintSmith Vision 
EFI will provide you with the URL to access your PrintSmith Vision server in the EFI Hosting Center. 

1. Enter the PrintSmith Vision URL in the address bar of your browser.  

2. If you get a message that Adobe Flash Player needs to be installed, click the link to download the player 
and then install it. (This is a one-time procedure.) 

After you install the player, restart the browser and enter the PrintSmith Vision URL again. 

3. In the login window, use admin/admin to log in as the administrator. 

Note For security reasons, EFI strongly recommends you change the admin password. To change 
your password, select Admin > Change Password.   

After you log in, the main window with the QuickAccess panel opens. For more information about this window 
and other PrintSmith Vision basics, see the PrintSmith Vision - Setup and User Guide. 
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Logging Out of PrintSmith Vision 
1. After you finish your work in PrintSmith Vision, always log off by clicking Logout on the menu bar.  

 
Note If you have a record open in PrintSmith Vision (for example, you are looking at a customer 

account), and you close the browser window without logging off, the record remains in a locked 
state so other users cannot open it. (Administrators can unlock records using Admin > 
System Monitor > Record Locks. For more information, see the “System Administration” 
chapter of see the PrintSmith Vision - Setup and User Guide. 

2. Close the browser window. 

What Does Not Apply in an EFI-Hosted Installation? 
This section summarizes the few PrintSmith Vision features that never apply when EFI is hosting PrintSmith 
Vision. The chapter that follows covers features that work slightly differently when PrintSmith Vision is EFI-
hosted, as well as features that apply only in EFI-hosted installations. 

With a few exceptions, the information in the PrintSmith Vision - Setup and User Guide about setting up the 
system, for example, establishing security; setting preferences; editing tables; creating tax tables; and defining 
charge, press, digital, and stock definitions; applies to all PrintSmith Vision installations whether EFI-hosted or 
customer-hosted. (The PrintSmith Vision - Setup and User Guide identifies any procedures that are different.) 

Likewise, except for the items noted in the next chapter, all the procedures for creating estimates and invoices, 
using point-of-sale (POS), posting payments, and performing other accounting tasks are the same. 

The following do not apply to PrintSmith Vision when it is EFI-hosted: 

• Local file folders 

The PrintSmith Vision -  Setup and User Guide includes references to files and folders on the server. 
Your server is not on a local computer so any references to folder locations do not apply to you.  

• PrintSmith Vision Monitor 

Ignore any references in the documentation to PrintSmith Vision Monitor. This is installed only when you 
are hosting PrintSmith Vision yourself. It does not apply to EFI-hosted installations. 

• Backups 

EFI takes care of all database and system backups. Ignore the section on “Backup Manager 
preferences” in the PrintSmith Vision - Setup and User Guide. 
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Overview 
This chapter covers those procedures or features that are slightly differently when PrintSmith Vision is EFI-
hosted: 

• E-mail setup 

• Customizing documents and reports 

• Fiery® integration  

• Receipt printing 

Setting Up E-Mail 
In PrintSmith Vision, you can e-mail documents such as estimates, invoices, statements, credit memos, and 
purchase orders. Before you can do so, you must configure your e-mail preferences. 

When PrintSmith Vision is EFI-hosted, you have two choices for configuring e-mail: 

• You can take advantage of EFI’s mailing infrastructure.  

• If your organization uses the Web-based version of Microsoft Outlook Exchange Server, you can 
configure an Outlook Exchange account.   

For information, see the “Use EFI mail” or “Set up Microsoft Exchange Server mail” under “E-Mail preferences” in 
the PrintSmith Vision – Setup and User Guide. 

Customizing Documents and Reports 
EFI supplies standard versions of documents such as estimates, invoices, job tickets, and purchase orders, but 
typically you will want to customize them, for example, add your logo, change a font, and so on. Likewise you 
may want to override some of the standard EFI reports with your own versions or add custom reports to the 
system. 

When PrintSmith Vision is EFI-hosted, you cannot customize reports directly on the server. Instead, you must 
have the following installed together on a client computer so you can customize reports locally and then upload 
them to the server: 

•  i-net Designer v 12.1 for modifying documents or reports or creating custom reports  

• Postgres  

• The correct version of Java  

• A copy of a PrintSmith Vision demo database  

Once all four are in place on the client computer you can customize documents and reports as described on 
page 22. 

Note If you want to customize documents and reports on more than one client computer, you must complete 
the setup instructions described below on each client computer. 

Overview of setup 
You were given the installers you need, as well as a copy of a PrintSmith Vision demo database. You must then 
complete these tasks: 

1. Install Postgres. 

2. Configure a local PrintSmith demo database in Postgres. 

3. Install correct version of Java (if not already installed). 

4. Install i-net Designer. 

5. Create a PrintSmith data source in i-net Designer to communicate with the PrintSmith database. 

Details of these tasks follow. 



Procedures That Are Different in an EFI-Hosted Installation  13  

 
 

 
 

Task 1: Install Postgres 
The PrintSmith Vision database is Postgres-based. Postgres must be installed locally if you plan to edit or create 
reports with i-net Designer. You will use the Postgres installer to install Postgres 9.3. 

1. Double-click postgresql-9.3.4-2-windows-x64.exe ( the Postgres 9.3 installer you were given).  

 
2. Follow the instructions in the initial Setup windows, for example, specify various installation folders 

(typically you will accept the suggested locations). 

3. In the Password step, enter and confirm PrintSmith^2012 as the password. 

 
4. In the Port step, leave the Port field set to 5432.  
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5. When asked for a Locale, select your language. 

 
6. Click Finish when the installation is done. (The installation may take a few minutes.) 

Task 2: Add the demo database  
As part of the Postgres installation, a utility named pgAdmin III was installed. Along with the installers you were 
also given a demo database. You will now use the pgAdmin utility to add the demo database so you can 
edit/create reports using i-net Designer against this database. (The database and i-net Designer must reside on 
the same computer.)  

1. Once Postgres is installed, go to All Programs and locate PostgreSQL 9.3 > pgAdmin III. 
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2. Start pgAdmin III, double-click PostgreSQL 9.3, and enter the same password that you entered during 
Postgres installation: PrintSmith^2012. 

 
3. Create a new empty PrintSmith database: 

a. Right-click Databases in the navigation pane and select New Database (or highlight Databases 
and select Edit > Create). 
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b. In the Name field in the New Database window, enter printsmith_db. 

c. In the Owner field, enter printsmith. 

d. Do not change anything else. 

e. Click OK. 

 
4. Add the demo database you were provided (printsmith_demo_db.backup) by “restoring” it: 

a. Right-click printsmith_db and select Restore. 
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b. Browse to the location where you put printsmith_demo_db.backup and click Restore. 

 

Task 3: Install Java 
To run i-net Designer (for editing and creating reports), you must have Java VM version Java SE 6 (or higher) 
installed on the computer.  

If you do not have this version installed, use the Java installer you were given. (You can also download the JDK 
installer from Java SE Downloads web site.) 

• To install Java, run jdk-6u26-windows-i586.exe.  

  

http://www.oracle.com/technetwork/java/javase/downloads/index.html
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Task 4: Install i-net Designer 
Clear Reports i-net Designer is the tool you use to edit and create reports. 

You must install i-net Designer on the same computer where you installed Postgres, the demo database, and 
Java. Use the i-net Designer installer you were given: clear-reports-12.1.631-setup.exe.  

1. Double-click clear-reports-12.1.631-setup.exe. 

2.  Select Designer in the first window. Then follow the instructions to complete the installation. 

 

Task 5: Create a data source 
For i-net Designer to communicate with your PrintSmith demo database (so you can write custom reports), you 
must create a PrintSmith data source in i-net Designer. 

1. In Windows, go to All Programs and locate i-net Designer; on a Macintosh, go to the Applications 
folder. 

2. Start i-net Designer. 

3. Select Options > Data Source Manager. 
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4. In the Data Source Manager window, select LocalPostgressql Server and click Add. 

 
5. In the Driver Selection window, select PostgreSQL and click OK. 
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6. In the PostgreSQL window, complete the Basic Settings tab as follows: 

a. In the Data Source Name field, enter PrintSmith (be sure to match the case as shown). 

b. In the User field, enter printsmith. 

c. In the Password field, enter printsmith. 

d. Select the Save Password check box. 

e. In the Host field, enter localhost. 

f. In the Database field, enter printsmith_db. 

7. Click Test Connection. When you get a message that the connection was successful, click OK. (If you 
do not get this message, make sure you entered the information as shown in the figure below and then 
test the connection again.) 
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8. Click the Optional Settings tab, make sure Port is set to 5432, and click OK. 

 
9. The PrintSmith data source is now listed in the Data Source Manager window. Click OK. 

 
You are now ready to create custom reports against the PrintSmith Vision demo database. 
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Customization process 
When PrintSmith Vision is EFI-hosted, you download report files from the PrintSmith Vision server, customize the 
reports on a client computer (where you installed Postgres, the demo database, and i-net Designer), and then 
upload your customized documents and reports to the server.  

Tip You use Report Manager to download and upload reports, but some reports can be downloaded and 
uploaded without Report Manager. These include invoices/estimates, statements, delivery tickets, and 
credit memos for journal entries. For details, see the PrintSmith Vision – Setup and User Guide. 

When you use i-net Designer to create custom reports or edit existing reports to customize them, you must select 
the PrintSmith data source you created (as described on page 18). 

Important This section just describes how to download and upload report files – how to get them from and to 
the PrintSmith Vision server and how to select your PrintSmith data source in i-net Designer. This 
is just one part of customizing documents and reports. Be sure to refer to the relevant sections of 
the PrintSmith Vision - Setup and User Guide for what different types of “reports” involve (for 
example, how to customize estimate and invoices or how to replace standard reports with your 
own versions). 

Downloading report files from the server 
When you download report files from the PrintSmith Vision server, they are placed in your default Downloads 
folder.  

Tips The location of the Downloads folder is specified in your browser settings. For example, in Chrome, this 
is one of the advanced settings; in Firefox it is one of the general options. 

1. In PrintSmith Vision, select Reports > Report Manager. 

Tip Some reports can be downloaded without Report Manager. These include invoices/estimates, 
statements, delivery tickets, and credit memos for journal entries. For details, see the 
PrintSmith Vision – Setup and User Guide 

2. Select the repository from which you want to download a report file: invoiceRepository is for estimates 
and invoices; reportRepository is for all other reports (including job tickets, delivery tickets, 
statements, purchase orders, and so on). 

Note Selecting invoiceRepository makes it faster to locate estimate and invoice reports, but they 
can also be selected (from the end of the list) if you select reportRepository. 

 
3. Click Download.  
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The Downloader window opens and lists all the report files that are available for download. 

4. Select the report you want and click Download File. 

 
The file is now available in your Downloads folder. You can now edit it with i-net Designer. 
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Using the PrintSmith data source when working with custom reports 
When you edit a report in i-net Designer or create a new custom report, you must select the PrintSmith data 
source you created earlier (as described on page 18). 

Important You must also select the PrintSmith data source when customizing an existing report. 

1. If editing a report: 

a. In i-net Designer, select Options > Data Source Manager. 

b. Select the PrintSmith data source you created. 

If creating a new report: 

a. In i-net Designer, select File > New, select Blank Report, and click the right arrow to continue. 

 
b. In the Datasource window, select the PrintSmith data source and click the right arrow. 
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c. In the navigation pane,  expand public to see the tables in the PrintSmith Vision demo database 
and then drag the tables you want to use to the right-hand pane. 

 
As you create your report, you will see something like this: 

 

Uploading report files to the server 
After you finish using i-net Designer to edit or create a report file on a client computer, you must upload it to the 
PrintSmith Vision server so it is available to all users. 

Note You cannot upload a report file which has an EFI_ prefix as part of the name. This is reserved for 
reports supplied by EFI. 

1. In PrintSmith Vision, select Reports > Report Manager. 

Tip Some reports can be uploaded without Report Manager. These include invoices/estimates, 
statements, delivery tickets, and credit memos for journal entries. For details, see the 
PrintSmith Vision – Setup and User Guide 
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2. Select the repository to which you want to upload a report file: invoiceRepository is for estimates and 
invoices; reportRepository is for all other reports (including job tickets, delivery tickets, statements, 
and so on). 

3. Click Upload. 

4. Locate the report file you want to upload and click Open. The system confirms the upload. 

5. Depending on the type of report you uploaded, complete any additional steps. For example: 

• If this is a custom report you are adding to Report Manager, select the Custom category, click 
Add, and select the report. You will then be able to run the report. (Until you add it, the report 
cannot be run.) 

• If you are replacing a standard report with one of your own, in Report Manager, select the Select 
file from server check box, select a Category, select the report you want to replace, and click 
Override. 

If you are customizing documents such as estimates and invoices, delivery tickets, printed journal 
entries (credit memos), purchase orders, or statements, see the PrintSmith Vision - Setup and User 
Guide for details. 
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Fiery Integration  
The integration between PrintSmith Vision and Fiery works as described in the PrintSmith Vision - Fiery 
Integration Guide except for an additional requirement and one difference when configuring a Fiery device.  

When PrintSmith Vision is EFI-hosted, to ensure communication between PrintSmith Vision and a Fiery, you 
must install a Remote Print Center (RPC) server on one of your PrintSmith Vision client computers that is 
connected to a Fiery. This RPC server then communicates with an RPC client that resides with your PrintSmith 
Vision server in the EFI hosting center. 

Similarly, RPC is required to print receipts from PrintSmith Vision. (For more information, see “Printing Receipts” 
on page 29.) 

Each PrintSmith Vision server communicates with a single RPC server so you will install RPC on one computer. 
This will allow communication with both a Fiery and a receipt printer.  

Installing RPC 
Important If you currently have a pre-3.5 version of RPC installed, contact EFI Support (see page 7) for help 

in uninstalling it.  

1. Obtain the RPC v. 3.5 Installer as instructed. 

2. Make sure the computer where you plan to install RPC meets the system requirements described on 
page 8. (For receipt printing, the receipt printer should be attached to this computer.) 

3. On the computer where you plan to install RPC, double-click the Installer. (On Windows, this is EFI 
RPC Installer.exe; on a Macintosh you receive a zip file named EFI RPC Installer.zip, which you must 
unzip to obtain the Installer.) 

4. Follow the instructions in the Installer.  

In the Get User Input window, be sure to enter the URL of your PrintSmith Vision server. 
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Uninstalling RPC 
Note If you currently have a pre-3.5 version of RPC installed, contact EFI Support (see page 7) for help in 

uninstalling it.  

If you need to uninstall RPC v. 3.5, run the Uninstaller from this folder: 

• Windows:  C:\Program Files\EFI\RPC\Uninstall RPCProxy 

•  Macintosh: /Applications/Uninstall RPCProxy 

The Uninstaller, however, does not automatically delete the installation folder so you must do so manually:  

• Windows: Delete C:\Program Files\EFI 

• Macintosh: Delete  /Applications/RPCProxy 

When you add a Fiery device 
When PrintSmith Vision is EFI-hosted, you must add a Fiery device by entering its IP address; you cannot 
search for Fiery devices. Ignore the “Add a Fiery device by searching for it” section in the PrintSmith Vision - 
Fiery Integration Guide. 
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Printing Receipts 
When PrintSmith Vision is EFI-hosted and you print receipts, you should install Remote Print Center (RPC) on a 
client computer to which the receipt printer is attached. RPC ensures communication between your PrintSmith 
Vision server and the receipt printer and avoids the need to preview a PDF of a receipt and select a printer 
before printing the receipt. 

Notes RPC is also used for communicating with a Fiery. 

 You can have only one RPC installation per PrintSmith Vision server. 

To take advantage of RPC for printing receipts 
1. As described on page 27, install RPC on a client computer to which the receipt printer is attached . 

2. If you did not already do so, configure the receipt printer as described in the PrintSmith Vision – 
Configuring Receipt Printers guide.  

Note If the printer was configured in a pre-3.5 version of PrintSmith Vision, clear the Use local 
printer for receipt print check box in the Cash Drawer preferences in PrintSmith Vision. This 
setting is no longer required. 

3. To print receipts from other client computers, make sure the receipt printer is shared as described in the 
PrintSmith Vision – Configuring Receipt Printers guide. 

4. Activate receipt printing using RPC: 

a. In PrintSmith Vision, click Preferences in the QuickAccess panel (or select Admin > Preferences). 

b. Under POS, select Cash Drawer. 

c. Select the Enable receipt printing through RPC check box. 

d. (Optional) For troubleshooting, select the Enable debugging of RPC check box. 

e. Click Save. 

 
Note Only one receipt printer (the one attached to the computer where RPC is installed) can take advantage 

of RPC and the simplified printing it offers. If you have more than one receipt printer, the other receipt 
printers (the ones not attached to the RPC computer) must be configured as described in the PrintSmith 
Vision – Configuring Receipt Printers guide. 

Select to 
activate receipt 

printing 
through RPC 
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About Managing Digital Assets 
In PrintSmith Vision, digital assets are the content files used to produce jobs. If a job includes a content file, you 
add it in the Job window (by clicking Digital Assets under Commands and then by clicking Add and uploading 
the file). The content files that you add to a job are listed in the Digital Assets window from which you can also 
preview and remove them. 

Note If you are integrated with Digital StoreFront®, content files uploaded for orders placed in Digital 
StoreFront are listed in the Digital Assets window, but are not stored the same way as files you upload 
from PrintSmith Vision. The Digital StoreFront files are managed and deleted in Digital StoreFront, not 
in PrintSmith Vision. 

 
If many jobs include content files, these digital assets start to use a large amount of storage space. When 
PrintSmith Vision is hosted by EFI, you are given 20 GB of storage space for your files, but have the option of 
purchasing additional space. 

The system is initially set to never delete digital assets, but typically you will want to have them deleted after a 
period of time, especially if files are often uploaded for one-time use or do not get re-used after a certain time.  

When the system is configured to delete digital assets, you can alert specific users when files are due to be 
deleted. The users can then use Digital Asset Manager to store the files locally if they think they might still need 
them.  
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Configuring Digital Asset Management 
By default, the system never deletes digital assets, but typically you will want to specify the amount of time you 
want to keep files before they are deleted, especially if many content files are for one-time use. You do this by 
setting the Digital Assets preferences. 

If you want to keep digital assets for particular customers for an amount of time that is different from what is 
specified in your Digital Assets preferences, you can set this in the customer accounts. Whatever you specify on 
the account level overrides the system setting in the Digital Assets preferences. 

To alert certain users that files are due to be deleted during the current week, you must edit their user definitions 
so they receive a message after they log into PrintSmith Vision. Users can then review the files due to be deleted 
and decide whether to keep them (by downloading them locally). 

Specify how long to keep digital assets 
By default, digital assets are never deleted. To set the period of time you want files kept before they are deleted, 
you must edit your Digital Assets preferences. Typically, you will want to control how long files are kept, 
especially if many of them are for one-time use.  

Tip If you prefer to keep files for a long time and end up exceeding the 20 GB of space you are allotted, you 
can always purchase additional space. 

Editing the Digital Assets preferences 
1. Click Preferences in the QuickAccess panel (or select Admin > Preferences). 

2. Go to System > Digital Assets. 

3. By default, Duration is set to Never. Specify how many Day(s), Week(s), or Month(s) you want to 
keep digital assets. 

4. Click Save. 

 
Note To calculate whether the digital assets for an invoice should be deleted, the system uses (a) the number 

of days between the current date and the date an invoice was last updated and (b) the duration (in 
days) specified in the Digital Assets preferences or the duration set in an account (as described next).  

Overriding the system setting on the account level 
If you want to keep digital assets for particular customers for a period of time that is different from the duration 
specified in the Digital Assets preferences, you can edit the customer account. If you set a file expiration duration 
for an account, this always overrides the system duration set in the Digital Assets preferences. 

1. Click Accounts in the QuickAccess panel (or select AR > Accounts). 

2. In the Account Picker window, select the account you want to edit. 
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3. Click the Settings tab. Initially, File Expiration is set to whatever your Digital Assets preferences are 
set to, for example, 7 days. 

 
4. To change the Duration: 

a. Under File Expiration, select the Use Account level setting check box. 

b. In the Duration field, specify how many Day(s), Week(s), or Month(s) you want to keep digital 
assets, for example, 1 month. 

 
5. Click Save on the toolbar. 
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Warn users that digital assets are due to be deleted 
The system automatically deletes content files according to your Digital Assets preferences (or account-level file 
expiration settings), but you can warn certain users when they log into PrintSmith Vision that files are due to be 
deleted that week. Those users can then review the files due to be deleted and download them locally if they 
want to keep them. 

Note Files are always automatically deleted at 11:00 P.M. on the Friday at the end of the week they are due 
to be deleted. 

1. Select Admin > User Definitions. 

2. In the list at the top of the window, select the user you want to warn about files about to be deleted. 

3. Select the Notify when digital assets are scheduled to be deleted check box. 

4. Click Save. 

5. Repeat steps 2 to 4 for all users you want to be notified. (It is a good idea to notify more than one user 
in case that user is away when files are due to be deleted.) 
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When these users log in, and files are due to be deleted that week, a message informs the users. The users can 
then review these files in Digital Asset Manager (as described next) and decide whether to keep them by 
downloading them. 

Using Digital Asset Manager 
If you configured some users (as described on page 35) to be notified at login that digital assets are due to be 
deleted in the current week, those users can then open Digital Asset Manager to review what is due to be 
deleted and download files they want to keep.  

 
In addition, you can use Digital Asset Manager at any time to review all the digital assets you currently have in 
the system and either delete them or download them.  

Note Files for web orders (for example, for Digital StoreFront orders) are listed in Digital Asset Manager, but 
you cannot delete or download them – these files are stored and handled differently.   

Open Digital Asset Manager 
• Select Admin > Digital Asset Manager. The Digital Asset Manager window opens. 

This window has two tabs: 

• The Due This Week tab lists all the files scheduled to be deleted this week. (This always takes place on 
Friday at 11:00 PM.) 

• The All tab lists all the digital asset files you have in the system (including those due to be deleted and 
those for web orders). 

At the bottom of the window you can see your Used Space versus Total Space.  

 
After you use 85% or more of your 20 GB allotted space, a warning is displayed at the bottom of the window. 
You can either delete files you no longer need (on the All tab in the Digital Asset Manager window) or contact 
EFI Sales to purchase additional space. 
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Review and manage what is due to be deleted 
On the Due This Week tab in the Digital Asset Manager window, you can review the files that are due to be 
deleted and download them if you want to keep them. 

Notes To calculate whether the digital assets for an invoice should be deleted, the system uses (a) the number 
of days between the current date and the date an invoice was last updated and (b) the duration (in 
days) specified in the Digital Assets preferences or the duration set in an account. (An account-level 
duration always overrides the system-level duration.)  

 Files are always automatically deleted at 11:00 P.M. on a Friday at the end of the week they are due to 
be deleted. 

1. Click the Due This Week tab. 

2. Change what is listed by doing any of the following: 

• By default, 10 files (records) are listed on a page. To change this number, in the Records per 
page field, select 10, 20, or 30. 

• Click a page number (bottom right) to move to the next or previous page of files. The number of the 
currently displayed page is in red. 

 
• Search by Document No. or Account Name.  

Note To clear a search, delete what you entered in these fields and press Tab. 

• To sort the list differently, click a column heading. For example, click Account Name to sort the list 
by account name. 

3. To review a file that is scheduled for deletion, select its check box and click Show Preview. 

4. To keep a file that is scheduled for deletion, select its check box and click Download. The file is saved 
in your Downloads folder. You can then move the downloaded file to a local folder of your choice. 

 

Review and manage all digital assets 
The All tab in the Digital Asset Manager window lists all the digital asset files you have in the system (including 
those due to be deleted and those for web orders). 

1. Click the All tab. 

2. Change what is listed by doing any of the following: 

• By default, 10 files (records) are listed on the page. To change this number, in the Records per 
page field, select 10, 20, or 30. 
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• Click a page number (bottom right) to move to the next or previous page of files. The number of the 
currently displayed page is in red. 

 
• Search by Document No. or Account Name.  

Note To clear a search, delete what you entered in these fields and press Tab. 

• To sort the list of files differently, click a column heading to sort by that column. For example, click 
Account Name to sort the list by account name. 

3. To review a file, select its check box and click Show Preview. (You can preview any file in the list.) 

4. If you know you want to keep a file, select its check box and click Download. The file is saved in your 
Downloads folder. You can then move the downloaded file to a local folder of your choice. 

Notes You can only download files that were added directly in PrintSmith Vision (in the Digital Assets 
window for a job). You cannot download files for web orders (for example, orders placed in 
Digital StoreFront).  

 If you select all the files (by selecting the check box to the left of the Name column), and any of 
the files are for web orders, the Download button will be unavailable. 

5. If you do not expect to need a file again, select its check box and click Delete.  

Note You can only delete files that were added directly in PrintSmith Vision (in the Digital Assets 
window for a job). You cannot delete files for web orders (for example, orders placed in Digital 
StoreFront).  

 If you select all the files (by selecting the check box to the left of the Name column), and any of 
the files are for web orders, the Delete button will be unavailable. 

 

When a digital asset is deleted 
When a digital asset is deleted (either automatically by the system or manually on the All tab in the Digital Asset 
Manager window), you can see this if you open the Digital Assets window for the job with which the file was 
associated. The file is still listed in the Digital Assets window, but is identified as purged and no longer available. 
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If the Connection Is Lost 
PrintSmith Vision is hosted by EFI and therefore relies on a network connection to transfer data to and from 
client computers. If the network connection fails while you are using PrintSmith Vision, records may get left in a 
locked state or some procedures (in particular closeouts and imports) may be left in an incomplete state. 

PrintSmith Vision can detect a drop in connectivity between your browser and the PrintSmith Vision server and 
give you the option to re-try or cancel.  

 
• If you click Re-Try, you can resume what you were doing when the network connection resumes. If the 

connection fails to resume, you are given the option to Re-Try/Cancel again. 

• If you click Cancel, you will lose whatever you were doing, and the window you were working in is 
closed. In addition, records may get left in a locked state or a closeout or a stock import may be 
unfinished. For information about handling these situations, see below. 

If Records Are Left Locked 
If you click Cancel when you are given the choice of Re-Try or Cancel when the network connection is lost, 
records may be left in a locked state. You can unlock any records that were locked by anything you (not another 
user) was doing when the connection was lost (even if you were using a different browser). 

1. Select Help > Session Utilities. 

2. Select the locked records and click Unlock Records. 

If You Were Doing a Closeout and Lost Connectivity 
If you lose the network connection while doing a closeout, you can click Re-Try, and the closeout will continue 
once the connection is restored. If, however, you click Cancel, the Closeout window closes, but the closeout is 
incomplete. In this case, new users are prevented from logging in and logged-in users continue to see the 
closeout warning (preventing work from being done). The closeout must be terminated and then re-started. 

You can terminate a closeout in three ways, after which it can be re-started. 

Method 1 
If you are a member of the owner or system admin group, or if you started the closeout, you can log in and click 
Yes when given the option to terminate the closeout. 

 

Method 2 
If you started the closeout (even if you are not a member of the owner or system admin group), you can log into 
the PrintSmith Vision server and click Yes when given the option to terminate the closeout (as shown in the 
figure above). 
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Method 3 
If you started a closeout, you can terminate it from the Help menu. (You cannot terminate a closeout that another 
user started.) 

1. After you click Cancel and the Closeout window closes, select Help > Session Utilities. 

2. Click Terminate Closeout. 

If You Were Importing Stocks and Lost Connectivity 
If you lose the network connection while importing stocks, you can click Re-Try, and the import will continue 
once the connection is restored. If, however, you click Cancel, the import is not completed, and users who log in 
are prevented from doing anything. The stock import must be terminated and then re-started.  

You can terminate a stock import in three ways, after which it can be re-started. 

Method 1 
If you are a member of the owner or system admin group, or if you started the import, you can log in and click 
Yes when given the option to terminate the import. 

 

Method 2 
If you started the stock import (even if you are not a member of the owner or system admin group), you can log 
into the PrintSmith Vision server and click Yes when given the option to terminate the import (as shown in the 
figure above). 

Method 3 
If you started the import, you can terminate it from the Help menu. (You cannot terminate a stock import that 
another user started.). 

1. Select Help > Session Utilities. 

2. Click Terminate Import. 
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Viewing Connection Failures 
When  you experience a loss in connection, you can analyze what was occurring when the connection was lost. 
This lets you see when the failure occurred and helps EFI Support analyze the cause of the failure.  

1. Select Help > Connection Failures. The Connection Failures window opens. 

2. Do any of the following: 

• Click Refresh to update the results. 

• Click Export to export the data to a CSV file.  

 

User Sessions and Network Connections 
Although the goal is to keep user sessions active when connectivity is resumed, in some cases the system ends 
user sessions and logs out users automatically. 

Case 1 

Conditions 

1. The user was logged into PrintSmith 

2. The connection was not lost  

3. The user was idle for 1 hour (meaning not performing any actions, including moving the mouse) 

Result 

The user session is cancelled and all records locked by that user are unlocked.  

Note If the Enable automatic log out setting in the Behavior preferences (Admin > Preferences > System 
> Behavior) is enabled, the user session is terminated according to this preference setting.   

Case 2 

Conditions 

1. User 1 was logged into PrintSmith 

2. The loss in connection was more than 15 minutes but less than 1 hour 

3. A new user login occurred (could be the same user from another computer) 

4. The connection was not resumed for User 1 
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Result 

The session for User 1 is cancelled and all records locked by that user are unlocked. 

Note If the connection for User 1 resumes after 15 minutes, but before a new login in occurs, User 1’s 
session remains active and records remain locked. 

Case 3 

Conditions 

1. The user was logged into PrintSmith 

2. The connection was lost, but was resumed within 15 minutes 

3. During the connection loss, user was prompted to Re-Try/Cancel, but failed to re-try for more than 15 
minutes 

Result 

The user session is cancelled and all records locked by that user are unlocked. 

Case 4 

Conditions 

1. The user was logged into PrintSmith 

2. The connection was lost for more than 1 hour  

3. No new user tried to log in 

Result 

The user session is cancelled and all records locked by that user are unlocked. 

Case 5 

Conditions 

1. The user was logged into PrintSmith 

2. The user closed the browser without logging out 

Result 

After 15 minutes, whenever a new login occurs, the user session is cancelled and all records locked by that user 
are unlocked. 

Case 6 

Conditions 

• The PrintSmith Vision server is re-started 

Result 

All user sessions are cancelled and all records that were locked are unlocked. Users receive a message about 
the session timeout when the server re-starts and they are logged out. 

Known Issues 
• If the connection fails while you are adding a Fiery device and synchronizing media, you get no option 

to re-try or cancel. You must terminate the operation and start again. 

• If the connection fails after you submit a job to a Fiery device, you are not notified if the job was 
submitted successfully or not. You also do not get an option to re-try or cancel. 
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