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About This Document 

This document describes the enhancements and corrections that were made in PrintSmith™ Vision 3.6.2. 

Contact Information 

EFI Support 

Web Site: https://customer.efi.com/support 

US Phone: 
1.855.EFI.4HLP 

480.538.5800 

UK Phone: +44 (0) 800.783.2737 

EU Phone: +49 (0) 2102.745.4500     

E-Mail: printsmith.support@efi.com 

 
Regular US Service Desk hours are 7 A.M. to 5 P.M. Mountain Standard Time, Monday – Friday 

Regular UK Service Desk hours are 8 A.M. to 5 P.M. Greenwich Mean Time, Monday – Friday 

Regular EU Service Desk hours are 9 A.M to 6 P.M. Central European Time, Monday – Friday   

Note For problems involving infrastructure (i.e., computers, networks, operating systems, backup software, 
printers, third-party software, etc.), contact the appropriate vendor. EFI cannot support these types of 
issues. 

EFI Professional Services 

US Phone: 651.365.5321 

US Fax: 651.365.5334 

US E-Mail: ProfessionalServicesOperations@efi.com 

Outside US E-Mail: EMEAProfessionalServicesOperations@efi.com 

 

EFI Professional Services can help you perform EFI software installations and upgrades. This group can also 
help you implement, customize, and optimize your EFI software, plus offers a range of training options. 

Important Information – Read This! 

Do You Meet System Requirements? 

Be sure you meet the system requirements listed on page 8. 

Important Mac OS X 10.10 is no longer a supported operating system for PrintSmith Vision servers, but Mac 
OS X 10.12 is now supported. If you already have PrintSmith Vision installed and are interested  in 
upgrading your operating system to 10.12, be sure to follow the instructions in “OS X 10.12 (Sierra) 
and existing PrintSmith Vision installations” on page 11.    

Macintosh OS X Installation Folder  

When you install PrintSmith Vision on a Mac, be sure to install it in the default Applications folder. Custom 
folders are not currently supported, and will prevent PrintSmith Vision from running.  

If You Are Upgrading from PrintSmith Classic 8.1 to PrintSmith Vision 

If you are upgrading from PrintSmith 8.1, make sure you have PrintSmith Classic 8.1.28 installed before you 
export your data. For complete details of upgrading, see the PrintSmith Vision - Installation and Upgrade Guide. 

https://customer.efi.com/support
mailto:printsmith.support@efi.com
mailto:ProfessionalServicesOperations@efi.com
mailto:EMEAProfessionalServicesOperations@efi.com
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If You Are Upgrading PrintSmith Vision 

If you have PrintSmith Vision installed, and are updating it, see “Upgrading PrintSmith Vision” on page 26.  

Known Issues 

PrintSmith server will be slow to start first time after upgrade to 3.6 

Because of changes to the database made in PrintSmith Vision 3.6, the server will take several minutes to start 
automatically the first time after the upgrade to 3.6. The time it will take depends on the size of your database 
and available system resources. 

Warning During the server startup, do not shut down the PrintSmith Vision server and do not open the 
PrintSmith Installation folder or any of its sub-folders. 

Overriding/uploading reports 

On some browsers an error occurs if you try to override a report from Report Manager or upload your own 
version of a report (for example, a customized statement, estimate, or delivery ticket).  

Workaround: Make sure the report you are trying to upload is not in one of the PrintSmith Vision report repository 
folders.  Move the report to another folder (or the desktop) and then try overriding or uploading. 
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System Requirements 

Overview 

The computer where PrintSmith Vision and its database are installed is known as the server. PrintSmith Vision is 
then accessed by users through a browser on Windows® or Macintosh® computers. These computers are also 
known as clients. 

Note If EFI is hosting PrintSmith Vision for you, the server requirements do not apply to you, but the client 
and other requirements do apply. 

This section describes the technical requirements you must meet for the PrintSmith Vision server (see below) 
and for the client computers (see page 12).  

In addition, to run PrintSmith Vision, you must meet some miscellaneous requirements such as browser version 
and monitor size and resolution. 

Starting with PrintSmith Vision 3.0, mobile views of parts of the PrintSmith system are available from 
smartphones and tablets. Requirements for taking advantage of mobile views are on page 14. 

Important Below are the system requirements for running PrintSmith Vision based on what was certified by EFI. 
If your environment is not listed below, then it has not been certified, and EFI cannot guarantee or 
support the results. 

PrintSmith Vision Server Requirements 

You can install PrintSmith Vision on a Windows or Macintosh computer as long as it meets the requirements 
listed below.  

Important Although you can run PrintSmith Vision on a shared server, EFI strongly recommends a dedicated 
server. Not only does performance degrade when several applications run on the server, but 
issues resulting from conflicting applications can be very difficult to diagnose. This type of 
diagnosis is therefore not supported by EFI. 

  PrintSmith Vision can run on a virtual machine (VM). While EFI supports PrintSmith Vision running 
in a virtual environment, EFI is not responsible for your virtual environment or its setup. EFI will use 
commercially reasonable efforts to investigate potential issues with PrintSmith Vision running on a 
virtual machine, but as part of that investigation, EFI may require the issue to be reproduced 
independently of the virtual machine environment. When issues are confirmed to be unrelated to 
the virtual environment, EFI will support PrintSmith Vision in a way that is consistent with the 
support provided when PrintSmith Vision is running in a non-virtual environment.  

Windows 64-bit 

Operating 
system: 

Windows 8 
Windows 10 ** 
Windows Server 2012 R2 Standard or Essentials 

Processor: Intel Quad Core i7 2.3 GHz 

Memory: 16 GB (more memory will improve performance) 

Hard drive: 50 GB free space 

** For Windows 10, be sure to read “Windows 10 and existing PrintSmith Vision installations” on page 9. 
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Windows 10 and existing PrintSmith Vision installations 

Windows 10 is supported for both the PrintSmith Vision server computer and client computers. If you want to 
upgrade your server to Windows 10, be sure to follow the instructions below for existing PrintSmith Vision 
installations. 

Important During an upgrade to Windows 10, PrintSmith Vision is currently removed so you will lose your 
PrintSmith system unless you follow the steps below. 

1. Back up your entire PrintSmith Vision system using the Backup Manager preferences as described in 
the “Backup Manager preferences” section of the PrintSmith Vision - Setup and User Guide. 

Important Store the backup on an external device or in the cloud to make sure your backed-up data 
stays safe during the upgrade. 

2. Deactivate your PrintSmith Vision license: 

a. Before you uninstall PrintSmith Vision, log into the system. 

b. Select Help > About PrintSmith. 

c. Click Update License. 
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d. In the Manage PrintSmith Options window, click Deactivate All.  

 

e. After the deactivation is confirmed, click Finish. 

3. Uninstall PrintSmith Vision. 

4. Upgrade your operating system to Windows 10. 

5. After the operating system is upgraded, install PrintSmith Vision and activate your license. (For 
installation instructions, see the PrintSmith Vision - Installation and Upgrade Guide.) 

6. Restore your database, custom documents/reports, and digital assets (content files) as described in the 
“Restoring the entire PrintSmith Vision system” section of the PrintSmith Vision - Setup and User Guide. 

Windows 10 and new installations of PrintSmith Vision 

If you are new to PrintSmith Vision, just install it on your Windows 10 computer as described in the PrintSmith 
Vision - Installation and Upgrade Guide.  

Macintosh 

Operating 
system: 

OS X 10.11, 10.11 Server, 10.12**, or 10.12 Server** 

Processor: Intel Quad Core i7 2.3 GHz 

Memory: 16 GB (more memory will improve performance) 

Hard drive: 50 GB free space 

** For OS X 10.12, be sure to read “OS X 10.12 (Sierra) and existing PrintSmith Vision installations” on 
page 11. 

 
OS X and new PrintSmith Vision installations  

Macs running OS X 10.11 and higher do not have Java installed, which is required to install PrintSmith Vision. 
Download and install Java before starting the PrintSmith Vision Installer. 
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OS X 10.12 (Sierra) and existing PrintSmith Vision installations 

OS X 10.12 is supported for both the PrintSmith Vision server computer and client computers. If you want to 
upgrade your server to OS X 10.12, be sure to follow the instructions below for existing PrintSmith Vision 
installations. 

Important During an upgrade to OS X 10.12, Apple currently removes a critical part of the PrintSmith Vision 
system. Follow the steps below to avoid having a non-functioning PrintSmith system. 

1. Back up your entire PrintSmith Vision system using the Backup Manager preferences as described in 
the “Backup Manager preferences” section of the PrintSmith Vision - Setup and User Guide. 

Important Store the backup on an external device or in the cloud to make sure your backed-up data 
stays safe during the upgrade. 

2. Deactivate your PrintSmith Vision license: 

a. Before you uninstall PrintSmith Vision, log into the system. 

b. Select Help > About PrintSmith. 

c. Click Update License. 

d. In the Manage PrintSmith Options window, click Deactivate All.  

 

e. After the deactivation is confirmed, click Finish. 

3. Uninstall PrintSmith Vision. 

4. Upgrade your operating system to 10.12 

5. After the operating system is upgraded, install Java. (Java is required for PrintSmith Vision installation.) 

6. Install PrintSmith Vision and activate your license. (For installation instructions, see the PrintSmith 
Vision - Installation and Upgrade Guide.) 

7. Restore your database, custom documents/reports, and digital assets (content files) as described in the 
“Restoring the entire PrintSmith Vision system” section of the PrintSmith Vision - Setup and User Guide. 
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Important notes about the server 

• If PrintSmith Vision is going to be accessed from other computers (clients), the server computer should 
have a static IP address. This IP address is part of the URL users enter to run PrintSmith Vision; if the 
IP address keeps changing (because it is not static), the URL will also keep changing. 

• The server computer must run 24/7 with the hard drive set to never sleep. If the hard drive goes to 
sleep, users who are running PrintSmith Vision from other computers will get a “server down” message, 
and will be unable to use PrintSmith while the hard drive is in sleep mode. On a Windows computer, 
turn off sleep mode in the Power Options settings in the Control Panel; on a Macintosh, turn off sleep 
mode in the Energy Saver settings. 

About operating system updates 

EFI strongly recommends that you do not have automatic operating system updates turned on. Instead do the 
updates manually at the same time as you update PrintSmith Vision. 

If you want to update the operating system at other times, do it manually and then make sure PrintSmith Vision 
works as expected. If necessary, revert the updates. 

PrintSmith Vision Client Requirements 

These are the requirements for running PrintSmith Vision on a client computer (one on which PrintSmith Vision is 
not installed): 

Operating 
system: 

Windows 7, 8, or 10 
Macintosh OS X 10.8 or higher 

Memory: 4 GB minimum (more memory will improve performance) 

Browser: See “Browser Requirements” below. 

Monitor: See “Monitor and Resolution Requirements” below. 

Browser Requirements 

The following browsers are supported for running PrintSmith Vision on a desktop: 

• Mozilla Firefox® 50.x or later  

• Safari® 8.x or later (OS X 10.11) and Safari 10.x or later (OS X 10.12) 

• Chrome™ 54 or later 

• Microsoft Edge (Windows only) 

Monitor and Resolution Requirements 

PrintSmith Vision is designed to be viewed and used on a large monitor with high resolution: 

• 19-inch monitor 

• Minimum resolution of 1280 x 1024  

Important If you are using a laptop, to see estimates and invoices in full, the height (second number) 
must be at least 1024 pixels.  

Network Requirements 

• 100 base T Ethernet 
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Internet Requirements 

In addition to being required to run PrintSmith Vision, Internet connectivity is required as follows: 

• For initial licenses of software 

• For upgrades and upgrade licenses 

• For Payment Plan users during defined periods of plan 

• For interaction with the EFI Support team 

Custom Document and Report Requirements 

PrintSmith Vision reports and other documents (such as estimates or invoices) are written in i-net Clear Reports. 

If you want to customize your estimates or invoices (for example, include your logo) or if you plan to create 
custom reports, you must install i-net Designer, which is part of Clear Reports. You are given the option of 
installing i-net Designer during the PrintSmith Vision server installation. 

Receipt Printer Requirements 

A receipt printer is optional in PrintSmith Vision, but if you want to use one, you must purchase the Star TSP 
700ll printer from EFI.  

For important information about configuring the receipt printer, see the guide PrintSmith Vision - Configuring 
Receipt Printers. 

Fiery Integrations 

If you are using PrintSmith Vision with a Fiery®, Fiery JDF version 1.5.0.36 is required. 

When PrintSmith Vision is EFI-hosted, Remote Print Center (RPC) is also required. See below for requirements. 

Remote Print Center (RPC) – EFI-Hosted Installations 

When PrintSmith Vision is EFI-hosted, Remote Print Center (RPC) is required for Fiery integrations and strongly 
recommended for receipt printing. 

The computer on which you install RPC must meet these hardware and software requirements: 

Operating system: Any 64-bit version of Windows or Macintosh OS X  

Processor: Dual core 

Memory: 4 GB  

Hard Drive: 50 – 100 GB 

 
In addition, the computer where you install RPC must: 

• For Fiery integration, have access to the Fiery device(s) you are using. 

• For receipt printing, be connected to the receipt printer. 

• Have access to the Internet, including access to PrintSmith Vision. 

• Run 24/7 with the hard drive set to never sleep. It must be available for communication all the time. 
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Digital StoreFront Integrations 

To use the eFlow-based integration of PrintSmith Vision with Digital StoreFront®, Digital StoreFront 9.6 or higher 
is required. 

Note For information about using PrintSmith Vision with Digital StoreFront, see the PrintSmith Vision – Digital 
StoreFront Integration Guide. 

If you host PrintSmith Vision yourself, you must also install eFlow on a Windows computer that meets the 
following requirements: 

Operating 
system: 

64-bit only: Windows 8, Windows 10, or Windows Server 2012 R2 Standard or 
Essentials 

Processor: Quad Core CPU, Intel i3 or higher 

Memory: 8 GB with 2 GB free for eFlow 

 
In addition, the computer must: 

• Have a static IP address. 

• Run 24/7 with hard drive set to never sleep. It must be available for communication all the time. 

Warning Although you can install eFlow on the PrintSmith Vision server (if it is a Windows computer with a 
static IP address), a separate computer is strongly recommended. You will require technical 
assistance if you try to install eFlow and PrintSmith Vision on the same computer. 

Mobile View Requirements 

As of PrintSmith Vision 3.0, mobile views of parts of the PrintSmith system are available from smartphones and 
tablets. Mobile views are based on HTML5 technology. This section describes devices, operating systems, and 
browsers that are fully compatible with HTML5 and can therefore support PrintSmith Vision mobile views. 

Mobile devices 

The following mobile devices are supported: 

• iPad® 4th and 5th generation 

• iPhone® 5 and 6 

• Android™ tablets 

• Android smartphones  

Mobile operating systems 

• iOS 8.3 

• Android 4.1, 5.1 

Browser requirements for mobile views 

The following browsers are supported: 

• Chrome 21 or higher 

• Safari 5 or higher 

Note Mozilla Firefox is not supported. 

  



Version 3.6.2  15  

 
 

 

 
 

New Features and Enhancements  

PrintSmith Vision 3.6.2 includes the following changes and enhancements. 

E-Commerce API  

The following enhancements were made to the e-commerce API. 

Client security for API calls 

To ensure security, you must include a token in the header of Post and Get transactions. This token is 
automatically generated by the system and is available at the bottom of the PrintSmith Integration preferences: 

 

The token must be supplied in this format: 

apitoken=token;date 

where 

• token is the API Token displayed in the Integration preferences  

• date is a UTC date in yyyy-MM-dd HH:mm:ss 24-hour format 

For example, apitoken=33b4250f-ac50-4150-a65a-bfccb555184c;date=2017-04-20 16:34:50 

Once the token is constructed based on the pattern shown above, apply Base64 encoding to the final token and 
send it as a request header with the header name token. 

Accounts: additional fields 

Additional account-related fields are now accessible through the e-Commerce API: 

Field Description 

balance Read-only 

merchandise_balance Read-only 

pending_invoice_balance Read-only 

pending_estimate_balance Read-only 

account_status Read-only, status of the account, e.g., New, Current, Delinquent 

master_account_id Read-only, numeric ID of the associated master account 

master_account_name Read-only, name of the associated master account 

do_not_mail Boolean (true or false) controls whether the account is ignored 
in mailings 

account_notes Notes (up to 255 characters) for the account 

custom_data_1 to custom_data_10 Custom marketing fields for the account 

sales_rep Must be defined in the Sales Rep table in PrintSmith Vision 

lead_source Must be defined in the Lead Source table in PrintSmith Vision 

business_type Must be defined in the Business Type table in PrintSmith Vision 

 

Sample Post account creation 

{ 
  "name": "Company 10", 
  "type": "Customer", 
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  "external_reference_number": "123", 
  "sales_rep": "Ron", 
  "lead_source": "Referral", 
  "business_type":"Multi-national", 
  "account_status": "New", 
  "do_not_mail": true, 
  "account_notes": "Check the instructions", 
  "custom_data_1": "custom data 1", 
  "custom_data_2": "custom data 2", 
  "custom_data_3": "custom data 3", 
  "custom_data_4": "custom data 4", 
  "custom_data_5": "custom data 5", 
  "custom_data_6": "custom data 6", 
  "custom_data_7": "custom data 7", 
  "custom_data_8": "custom data 8", 
  "custom_data_9": "custom data 9", 
  "custom_data_10": "custom data 10", 
 
"addresses": [ 
    { 
      "type": "statement", 
      "address_1": "Building A", 
      "address_2": "11 Bay Rd", 
      "suburb": "Cambridge", 
      "postcode": "02141", 
      "country": "USA" 
    }, 
    { 
      "type": "invoice", 
      "address_1": "Building A", 
      "address_2": "11 Bay Rd", 
      "suburb": "Cambridge", 
      "postcode": "02141", 
      "country": "USA" 
    } 
  ], 
  "credit_control": { 
    "type": "Charge Account", 
    "credit_limit": 20000 
  }, 
   
  "automatic_discount": { 
    "type": "percentage", 
    "amount": 0 
  }, 
   
  "contacts": [ 
    { 
      "type": "invoice", 
      "first_name":"Jane", 
      "last_name": "Benson", 
      "phone": "1112223333", 
      "cell": "1112223434", 
      "fax": "112223322" 
    }, 
    { 
    "type": "statement", 
      "first_name":"Jane", 
      "last_name": "Benson", 
      "phone": "1112223333", 
      "cell": "1112223434", 
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      "fax": "112223322" 
    } 
  ] 
   } 

Sample Get response 

{ 
  "id": 51201, 
  "account_id": "48", 
  "name": "Company 10", 
  "type": "Customer", 
  "addresses": [ 
    { 
      "type": "statement", 
      "address_1": "Building A", 
      "address_2": "11 Bay Rd", 
      "suburb": "Cambridge", 
      "postcode": "02141", 
      "country": "USA" 
    }, 
    { 
      "type": "invoice", 
      "address_1": "Building A", 
      "address_2": "11 Bay Rd", 
      "suburb": "Cambridge", 
      "postcode": "02141", 
      "country": "USA" 
    } 
  ], 
  "credit_control": { 
    "type": "Charge Account", 
    "credit_limit": 20000 
  }, 
  "external_reference_number": "123", 
  "sales_rep": "Ron", 
  "account_status": "New", 
  "automatic_discount": { 
    "type": "percentage", 
    "amount": 0 
  }, 
  "master_account_id": -1, 
  "do_not_mail": true, 
  "balance": 77.02, 
  "merchandise_balance": 77.02, 
  "master_account_name": "", 
  "account_notes": "Check the instructions", 
  "custom_data_1": "custom data 1", 
  "custom_data_2": "custom data 2", 
  "custom_data_3": "custom data 3", 
  "custom_data_4": "custom data 4", 
  "custom_data_5": "custom data 5", 
  "custom_data_6": "custom data 6", 
  "custom_data_7": "custom data 7", 
  "custom_data_8": "custom data 8", 
  "custom_data_9": "custom data 9", 
  "custom_data_10": "custom data 10", 
  "lead_source": "Referral", 
  "business_type": "Multi-national", 
  "pending_invoice_balance": 0, 
  "pending_estimate_balance": 154, 
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  "contacts": [ 
    { 
      "type": "statement", 
      "first_name": "Jane", 
      "last_name": "Benson", 
      "phone": "1112223333" 
    }, 
    { 
      "type": "invoice", 
      "first_name": "Jane", 
      "last_name": "Benson", 
      "phone": "1112223333" 
    } 
  ] 
} 

Contacts: enhancements to Post/Get transactions  

The following enhancements and changes were made to the Post and Get transactions for contacts: 

Field Description 

do_not_mail Boolean (true or false) controls whether the contact is ignored in mailings  

sales_rep  Read/write, must be defined in the Sales Rep table in PrintSmith Vision 

phone Is now read/write 

cell Is now read/write 

email Is now read/write 

Invoice: enhancements to Post/Get transactions  

The following enhancements and changes were made to the Post and Get transactions for invoices: 

Field Description 

include_account_charges Boolean (true or false) controls whether the default charges for the 
account, invoice, and job are included in the invoice 

first_name (in contact object) First name of temporary contact 

last_name (in contact object) Last name of temporary contact 

phone (in contact object) Phone of temporary contact 

fax (in contact object) Fax of temporary contact 

cell (in contact object) Mobile phone of temporary contact 

email (in contact object) E-mail address of temporary contact 

wanted_by_date Can be null (no date) 

reorder_date Can be null (no date) 

proof_date Can be null (no date) 

po_number Read/write 

customer_discount Read only, customer discount (currency) 

web_reference_number Read-only after initial invoice creation 

ship_price Read/write, shipping amount 

ready_for_pickup Boolean (true or false) controls whether the invoice is ready for 
pickup 

special_instructions Read/write 
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sales_rep Read/write, must be defined in the Sales Rep table in PrintSmith 
Vision 

taken_by Read/write 

on_pending_list Boolean (true or false) controls whether the invoice is on the pending 
list 

pickup_date Read-only, the date invoice was picked up 

completed_date Read-only, the date the invoice was completed 

 

In addition, the following changes were made to the job fields (under items): 

Field Description 

index Index number of the job 

location_name  Read-only, the location name 

location_id Read/write, the location ID 

sheets Read-only, the number of sheets in the job 

up Read-only, number of images on run sheet 

on Read-only, number of unique images 

stock_number Read-only, the stock number 

stock_name Read-only, the stock name 

press_copies Read-only, the number of press copies 

print_services An array with an id (Digital StoreFront ID) and price (price of charge) 

 

For example: 

{ 
    "account_account_id": "2717", 
    "include_account_charges": true, 
    "items": [ 
        { 
            "index": 2, 
            "print_services": [ 
                { 
                    "id": 545 
                } 
            ] 
        } 
    ] 
} 

Estimates: enhancements to Post/Get transactions  

The following enhancements and changes were made to the Post and Get transactions for estimates: 

Field Description 

include_account_charges Boolean (true or false) controls whether the default charges for the 
account, invoice, and job are included in the estimate 

first_name (in contact object) First name of temporary contact 

last_name (in contact object) Last name of temporary contact 

phone (in contact object) Phone of temporary contact 

fax (in contact object) Fax of temporary contact 
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cell (in contact object) Mobile phone of temporary contact 

email (in contact object) E-mail address of temporary contact 

wanted_by_date Can be null (no date) 

proof_date Can be null (no date) 

ship_price Read/write, shipping amount 

special_instructions Read/write 

sales_rep Read/write, must be defined in the Sales Rep table in PrintSmith 
Vision 

taken_by Read/write 

 

In addition, the following changes were made to the job fields (under items): 

Field Description 

index Index number of the job 

location_name  Read-only, the location name 

location_id Read/write, the location ID 

 

Pending list 

You can use /Commerce/PendingList to obtain either the full pending list or the pending list items for a 
particular account. 

Note that: 

• The account_walkin field is a Boolean (true/false) 

• The doc_type can be I (invoice) or E (estimate) 

• The balance_due reflects deposits and payments 

For example:  
 
/Commerce/PendingList 
{ 
  "pending_docs": [ 
    { 
      "account_id": 51201, 
      "account_account_id": 48, 
      "account_name": "Company 10", 
      "account_walkin": false, 
      "doc_type": "E", 
      "doc_number": "107", 
      "doc_number_prefix": "Cax", 
      "doc_number_suffix": " F50", 
      "doc_title": "Promotional Brochures", 
      "ordered_date": "24-04-2017 07:38", 
      "wanted_date": "30-04-2017 03:26", 
      "delivery_date": "30-04-2017 03:26", 
      "proof_date": "30-04-2017 15:26", 
      "balance_due": 143, 
      "hold_state": "In Storage", 
      "doc_location": "Prepress", 
      "taken_by": "web_order", 
      "sales_rep": "Ron", 
      "web_reference": "4", 
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      "job_count": 2 
    } 
] 
} 
 

Post payments – open items 

You can obtain the open items for an account with a Get transaction using /Commerce/PostPayment. You can 
either provide an account_id (the primary key) or account_account_id (the account number in the Customer 
window in PrintSmith Vision). 

Note the following: 

• The Type can be Invoice, JE (journal entry), or Finance Charge 

• The balance is the amount due and can be positive or negative 

For example: 

/Commerce/PostPayment?id=20110 
{ 
  "post_payments": [ 
    { 
      "account_id": 20110, 
      "transaction_id": 20188, 
      "ref_number": "170", 
      "type": "Invoice", 
      "posted_date": "03-05-2017 10:33", 
      "description": "Letterhead - Electronic - 6269-2030 - Nickname: Christopher J. Delello", 
      "balance": 165, 
      "invoice_total": 165, 
      "invoice_tax": 15, 
      "invoice_customer_po": "" 
    }, 
    { 
      "account_id": 20110, 
      "transaction_id": 20219, 
      "ref_number": "", 
      "type": "Finance Charge", 
      "posted_date": "03-05-2017 10:34", 
      "description": "Finance Charge", 
      "balance": 2.48 
    }, 
    { 
      "account_id": 20110, 
      "transaction_id": 20235, 
      "ref_number": "170", 
      "type": "JE", 
      "posted_date": "03-05-2017 10:36", 
      "description": "Adjust Invoice #170", 
      "balance": -15 
    }, 
    { 
      "account_id": 20110, 
      "transaction_id": 20248, 
      "ref_number": "", 
      "type": "Payment", 
      "posted_date": "03-05-2017 12:17", 
      "description": "Payment Cash", 
      "balance": -500 
    } 
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  ] 
} 
 

Post payments – applying payments 

You can post payments for open items in an account with a Post transaction using /Commerce/PostPayment. 
You can either provide an account_id (the primary key) or account_account_id (the account number in the 
Customer window in PrintSmith Vision).  

Note the following: 

• Each item is identified by a transaction_id. 

• The type is one of the following payment types: CC, cash, check, or draft. 

• The reference is a reference number, e.g., check number. 

• The cc_code identifies the type of credit card used (e.g., Visa or American Express). The cc_code 
must correspond to one of the unique two-character codes defined in the Code field in the Credit Card 
Info preferences. 

/Commerce/PostPayment?id=20110 
{ 
    "items": [ 
        { 
            "transaction_id": 9543321 
        }, 
        { 
            "transaction_id": 9543313 
        }, 
        { 
            "transaction_id": 9788237 
        }, 
        { 
            "transaction_id": 9788074 
        } 
    ], 
    "payment": { 
        "type": "CC", 
        "amount": 500, 
        “cc_code”: “VI”, 
        "reference": "XYZ" 
    } 
} 

Convert estimates to invoices 

You can convert an estimate to an invoice using /Commerce/ConvertToInvoice and providing the estimate 
number and production location identified by the unique Key (Alpha) field in the Production Locations table.  

The invoice that is created includes the original web reference number and is identified with a globe icon to 
indicate it originated outside PrintSmith Vision. 

For example: 

{ 
"estimate_number": 200, 
"location_key": AA100 
} 
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Obtain PDF of estimate or invoice 

You can obtain the PDF for an estimate or invoice using /Commerce/InvoicePDF. The PDF contents are 
encoded in Base64. 

You can provide three parameters: 

• doc_type: I for invoice or E for estimate. 

• invoice_number: the invoice or estimate number. 

• format_name: the name of the document format (preferences) to be used. If this is left blank, the 
default format is used. 

Obtain company information 

You can obtain company information from the Company preferences using /Commerce/Company. 

For example: 

{ 
  "address": { 
    "company": "EFI PrintSmith", 
    "street1": "9035 S. Kyrene Rd.”, 
    "street2": "Suite 106", 
    "city": "Tempe", 
    "state": " AZ", 
    "zip": "85284", 
    "country": "" 
  }, 
  "phone": "480-538-5800", 
  "email": "sales@printsmith.com", 
  "other1": "www.printsmith.com", 
  "other2": "Tadak Holding's Pty Ltd", 
  "company_id_label": "ABN", 
  "company_id": "97 009 344 398", 
  "store_number": "F034" 
} 

Provide content file and have it converted to digital asset 

You can provide a content file for a job in an estimate or invoice and have it listed as a digital asset in PrintSmith 
Vision where it can be previewed. 

Under the items array:  

• Use index to identify the job in the estimate/invoice 

• Include digital_asset_files 

• Include the file_contents with the file contents encoded in Base64 

• Include the file_name with an extension 

For example: 

{ 
 "items": [ 
  { 
   "index": 2, 
   "digital_asset_files": [ 
    { 
   "file_contents": in Base64 (not shown) 
                                    "file_name": "RPCSilentPrint.png" 
    } 

mailto:sales@printsmith.com
http://www.printsmith.com/
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  } 
 ] 
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Credit card type for deposits 

When a deposit is made through the API, you can now include a cc_code to identify the type of credit card used 
(e.g., Visa or American Express). The cc_code must correspond to one of the unique two-character codes 
defined in the Code field in the Credit Card Info preferences.  

SSL and HTTPs  

Beginning with v. 3.6.2, all users with SSL setup who attempt to access the site via http URL will be redirected to 
https URL and receive the appropriate message. (Enhancement issue: 18409)  

Corrections 

The sections that follow describe the corrections that were made in PrintSmith Vision version 3.6.2. For your 
convenience they are categorized. 

Accounts 

Account status 

Account status is now changing to “Current” when items in the account history have occurred within the defined 
inactive period. (Issue Reference: 18006) 

Administration 

Dates 

• The ability to add a date using the +XX date method is restored. (Issue Reference: 18408) 

Discounts 

Customer automatic discounts 

• Customer Accounts that have the Customer Automatic Discounts % enabled (Credit Control tab) now 
correctly apply the Customer Automatic Discounts to new documents copied from Account History 
documents. (Issue Reference: 18267) 

Estimating 

Invoices and estimates 

• Changing fields in the Job window that affect pricing (e.g., changing order quantity) and then tabbing to 
the next field no longer causes an error message. (Issue Reference: 18402) 

Jobs 

• For outside services jobs, the Overs Unit Price field can now display up to 8 decimal places. (Issue 
Reference: 17977) 
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• When job tickets are printed for individual jobs in a multi-part job, they are now correctly identified by 
number, e.g., 1 of 3. (Issue Reference: 18097) 

• Price reflected on a saved invoice is no longer being calculated based on the last specified Multi-qty 
value when Do not discount is enabled. (Issue Reference: 18376) 

Importing stock 

• PrintSmith Vision will now convert standard media size names (e.g., Letter, A3, A4) into dimensions 
when media are imported into the stock catalog. Note: This fix will not repair any existing stocks that 
have corrupted values in parent size. (Issue Reference: 17206) 

Purchase Orders 

• The Unit Price field in the Purchase Order Line Item window can now include up to 8 decimal places. 
(Issue Reference: 17976)  

Reports  

Loyalty point processing 

• The Loyalty Report now correctly calculates loyalty point value when a customer has an invoice with a 
deposit paid. Previously, the report was not showing the entire value of the invoice payment but only the 
final payment amount (minus the deposit paid). (Issue Reference: 18070) 

Charges missing from reported job price 

• Reports now accurately include all charges (e.g., in certain cases the reported job price was missing 
some charges, i.e., “press proof”). (Issue Reference: 18014) 

Web product template SKUs 

• Reports now show the SKU for the Web Product Template used to create jobs. (Issue Reference: 
17954) 

Taxation  

Error when product tax table associated with charge definition 

• Resolved the issue that was causing the following error message when saving certain templates:  
"Error: Server.Processing - null - failed to lazily initialize a collection of role: com.efi.printsmith.data.Tax 
table.taxelements, no session or session was closed." This was happening when a product had a tax 
table associated with a charge definition. (Issue Reference: 18456) 

Voids 

Partial voids on Tape window 

• Partial void is no longer possible. Previously, it was possible to perform a partial void, which resulted in 
data corruption. Selecting even a single line item now will result in selection and voiding of an entire 
block. (Issue Reference: 18353) 

Digital StoreFront Integration 

• When a Digital StoreFront order is for a printing (offset) product in PrintSmith Vision, the number of 
sheets that are calculated for the job in PrintSmith Vision are based on the page count and number of 
sides in the order. For duplex jobs, the page count is divided by 2 and rounded up. For example, if the 
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page count is 17, the number of sheets will be 9. For single-sided jobs, the page count and sheet count 
are the same. (Issue Reference: 18115) 

• Resolved the issue that was causing a price discrepancy between PrintSmith Vision and Digital 
StoreFront resulting from a job’s stock cost calculation error when PrintSmith Vision encountered the 
Charge Customer for Entire Order field. (Issue Reference: 18218) 

Upgrading PrintSmith Vision 

About Upgrading 

If you were already using an earlier version of PrintSmith Vision, but want to upgrade to version 3.6, you update 
your existing installation by running the 3.6 installer. You must, however, be upgrading from PrintSmith Vision 
3.5, not a pre-3.5 version.  

An upgrade requires a re-start of the server computer.  

Important: Before You Begin the Upgrade 

Have your license activation code (LAC) ready 

As of PrintSmith Vision 3.5, the Installer now checks your license to see if your maintenance contract is current 
(unexpired). You will need to enter your LAC so the Installer can perform this validation. 

Note If you already entered your LAC in PrintSmith Vision 3.5, you do not have to enter your license code 
again, but the Installer will perform the validation. 

To locate your LAC, do one of the following: 

• In PrintSmith Vision, select Help > About PrintSmith and then click Update License. Your LAC is 
listed below PrintSmith Vision Base System. 

• Locate the original activation e-mail you received from EFI. This includes your LAC. 

Note If you have problems locating your LAC, please contact EFI Support. 

If you also plan to upgrade the operating system 

If you plan to upgrade your operating system as well as PrintSmith Vision, be sure to follow these instructions to 
avoid losing data: 

• For upgrades to Windows 10, see “Windows 10 and existing PrintSmith Vision installations” on page 9. 

• For upgrades to Mac OS X 10.12 (Sierra), follow the instructions in “OS X 10.12 (Sierra) and existing 
PrintSmith Vision installations” on page 11. 

If you want to use an SSL connection 

Support for SSL (Secure Sockets Layer) connections was introduced in PrintSmith Vision 2.3. SSL creates an 
encrypted connection between the PrintSmith Vision server and your users’ browser, preventing eavesdropping 
and data tampering. When you use SSL, the URL to your server is prefaced by https:// instead of http://.  

Note To use SSL, you must purchase an SSL certificate from a certificate authority (CA) and then install and 
configure it (with the help of EFI Support). The certificate must be compatible with Apache Tomcat 
version 7. 

A non-SSL connection (which is the default connection between PrintSmith Vision and users’ browsers) is not 
encrypted. This means data transmitted to and from the server could in theory be seen by others. 

Important Even if you use non-SSL, credit card information is never at risk. This information is never stored in 
PrintSmith Vision, and USA ePay ensures the security of the transmission of credit card 
information.  
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  If you are unfamiliar with SSL and SSL certificates, EFI strongly recommends you use the default 
non-SSL connection. 

  Some organizations may have policies requiring SSL for all data exchange over the Internet, in 
which case they can take advantage of this new SSL functionality in PrintSmith Vision. 

If you did not previously configure SSL, during the upgrade process, you will be given the choice of using a non-
SSL (the default) or SSL connection. Keep in mind that an SSL connection: 

• Requires the purchase and installation of an SSL certificate. The certificate must be purchased from a 
Certificate Authority (CA) and be compatible with Apache Tomcat v. 7.  

• Requires the help of PrintSmith Support to install and configure the signed certificate your purchased. 

• Changes the PrintSmith Vision URL: the URL begins with htpps:// and uses port 8443 by default. 

Upgrade Your System 

Warning You must have PrintSmith Vision 3.5 installed before you can upgrade to 3.6.  

1. Be sure to read “Important: Before You Begin the Upgrade” on page 26. 

2. Back up your entire system as described in the section on “Backup Manager preferences” in the 
PrintSmith Vision - Setup and User Guide. 

3. Obtain the PrintSmith Vision Server 3.6 installer. 

Caution Before you start the installer, close PrintSmith Vision Monitor, pgAdmin, and any PrintSmith 
Vision installation folders that are open. 

4. Start the installer. 

5. After you accept the license agreement, enter your LICENSE ACTIVATION CODE (LAC) if you did not 
enter it previously. For information about locating your LAC, see “Have your license activation code 
(LAC) ready” on page 26. 

If your maintenance contract is current (unexpired), you can continue with installation; if it has expired, 
contact EFI Sales to renew your maintenance contract. You cannot continue with installation until your 
maintenance contract is updated. 

Notes If you are not connected to the Internet while running the Installer, you can select the 
Currently do not have Internet connection check box, obtain an offline activation code from 
EFI Support, and enter this code (as well as your LAC) to proceed with installation. (The offline 
activation code is valid for 24 hours.) 

 You only have to enter your LAC once. After your license is validated, the next time you run 
the Installer the LICENSE ACTIVATION CODE field will automatically include your code 
(which the Installer will then check to make sure your maintenance contract has not expired).   
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6. After you read some warnings about performing backups and closing all PrintSmith applications, if you 
are given this option, select Non SSL (the default) or SSL. For more information about this choice, see 
“If you want to use an SSL connection” on page 26.  

Notes If you selected SSL in a previous release of PrintSmith Vision, you will not be given the choice 
to select Non SSL or SSL. 

 If you select SSL, you must install and configure your SSL certificate after you upgrade 
PrintSmith Vision. Contact PrintSmith Support for help with this. 

 

7. Follow the remaining instructions to complete the upgrade. A re-start of the computer is required at the 
end of the upgrade.  
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After the Upgrade 

Server will be slow to start the first time after the upgrade 

Because of changes to the database made in PrintSmith Vision 3.6, the server will take several minutes to start 
automatically the first time after the upgrade to 3.6. The time it will take depends on the size of your database 
and available system resources. 

Warning During the server startup, do not shut down the PrintSmith Vision server and do not open the 
PrintSmith Installation folder or any of its sub-folders. 

Clear the browser cache 

To ensure you are seeing all the latest changes to the user interface, clear your browser cache after upgrading 
PrintSmith Vision. You only need to do this for any browser that you used to run PrintSmith Vision in the past. 
For instructions on clearing the browser cache: 

Chrome https://support.google.com/accounts/answer/32050?hl=en 

Firefox https://support.mozilla.org/en-US/kb/how-clear-firefox-cache 

Safari https://answers.syr.edu/display/software/Clear+Cache+in+Safari+version+7+on+Mac+OSX 

Microsoft Edge https://support.microsoft.com/en-us/help/10607/windows-10-view-delete-browser-history-
microsoft-edge 

 

Important  Make sure all your users clear their browser cache, too. 

  

https://support.google.com/accounts/answer/32050?hl=en
https://support.mozilla.org/en-US/kb/how-clear-firefox-cache
https://answers.syr.edu/display/software/Clear+Cache+in+Safari+version+7+on+Mac+OSX
https://support.microsoft.com/en-us/help/10607/windows-10-view-delete-browser-history-microsoft-edge
https://support.microsoft.com/en-us/help/10607/windows-10-view-delete-browser-history-microsoft-edge
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Appendix: Security 

This document summarizes recent changes made in PrintSmith Vision security.  

Insufficient data validation is performed  

User input and output to and from an application is the route for malicious payloads into and out of the system. 
All user input and output should be checked to ensure it is both appropriate and expected. Failing to perform 
proper input and output validation can lead to Directory Traversal, Insecure File Upload, Cross-Site Scripting 
(XSS) and a myriad of other security related issues.  

Insecure file upload practices are in use  

File upload capability allows a user to send a file from their computer to the web server. If the web application 
that receives the file does not carefully examine it for malicious content, an unauthenticated attacker may be able 
to use file uploads to execute arbitrary commands on the server with the permissions of the web server user.  

Directory traversal vulnerability was detected  

Remote file viewing is possible on the system because the application fails to parse out traversal strings (\..\..\) 
within an input request. An unauthenticated attacker can use this to retrieve the source code of scripts, obtain 
usernames and passwords, and access other sensitive information. 

Authorisation model does not adequately protect application 
resources.  

Authorisation is the act of checking whether a user has proper permission to access a particular resource after a 
user has been authenticated. With a forceful browsing attack, the attacker gains access to a restricted page 
within a web application by supplying a URL directly (forcing the URL) rather than by accessing it by following 
links from other pages in the application. The intended workflow to get to the restricted page is through another 
page which authorises the user to access the target page. This attack also allows an attacker to gain access to 
resources to which no direct links exist.  

The web application allows an unauthenticated user to view restricted content via direct object reference (forceful 
browsing). This includes access to resources an anonymous user should not have access to.  

Sensitive network traffic is unencrypted in transit across an untrusted 
network  

Sensitive network traffic from the application is not encrypted as it traverses the Internet. Without an 
appropriately encrypted communication channel, sensitive details could be intercepted by attackers. Depending 
on the environment, this might be passwords or private information such as Personally Identifiable Information 
(PII) or financial data.   

Tomcat administrative interface is accessible over the Internet  

Providing access to the management interface increases the attack surface for hackers. The exposure of these 
interfaces could allow attackers to perform automated password-based attacks against the management 
interfaces and potentially gain privileged access. Permitting access to management interfaces from any location 
can create significant security exposures. Security best practice recommends limiting accessible and active 
services to only those that are absolutely necessary. By reducing the number of exposed services, it is possible 
to reduce the likelihood of security breaches, as there are fewer services to configure, manage, update and 
audit.   
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Flash application is vulnerable to CVE-2011-2461   

A vulnerability has been identified in the Adobe Flex SDK which could lead to cross-site scripting issues in Flex 
applications. A user could be forced to visit a malicious site, which would eventually load the vulnerable Flash file 
from the PrintSmith application and subsequently steal the user’s cookies and data for the PrintSmith application.   

Post upgrade instructions  

Browser Cache clear   

End user using PSV needs to clear the browser cache after upgrading PSV security patch.  

Bookmark update  

If user has bookmark the Print Smith server URL, then URL should be prefaced by https:// instead of http://.  

 Authorization impact on accessing reports   

If less authorized Print Smith user is accessing the following report through URL, then those report will not able 
access, unless the PrintSmith user have following “ANY OF” permission for given report.  

  

Report name  Primary permission (Any one)  Secondary 

permission (Any one)  

Mailing Labels  Reports->Mailing Labels  File->Print  

Stock Definitions  Pricing->Stock Definitions  File->Print  

Import Stock Catalog  Pricing->Import Stock catalog    

Daily closeout reports  AR->Daily Closeout  

Reports->Daily Sales  

  

Monthly closeout 

reports  

AR->Monthly Closeout  

Reports->Monthly Sales  

  

Account History 

Analysis  

Reports->Account History    

Deposit Ticket  Reports->Deposit Ticket  

AR->Daily Closeout  

Reports->Daily Sales  

AR->Monthly Closeout  

Reports->Monthly Sales  

  

Account History  Reports->Account History  File->Print  

Charge Definitions  Pricing->Charge Definitions  File->Print  

Press Definitions  Pricing->Press Definitions  File->Print  

Copier Definitions  Pricing->Digital Definitions  File->Print  

Estimate History  Reports->Estimate History  File->Print  
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Report name  Primary permission (Any one)  Secondary 

permission (Any one)  

Journal Entry  AR->Journal Entry  File->Print  

Invoice reports  Invoice->Review Any Doc  

POS->Pending List Open  

POS->Cash Register window  

POS->Open Cash Register  

AR->Post Payments  

File->Print  

Job Ticket  Jobs->Print Job Ticket    

Delivery Ticket  Invoice->Generate Delivery Ticket  

Admin->Delivery Ticket Manager  

File->Print  

Aging reports  AR->Account Aging    

Statement reports  AR->Generate Statements    

All custom reports  Reports->Report Manager    

  

  

 


