macOS 13 Ventura compatibility


(See this page for macOS 11 Big Sur compatibility.)
(See this page for macOS 12 Monterey compatibility.)

We will update this webpage as compatible products are released. Please see EFI Communities for more information. 

For best results, run Fiery software only on the supported operating systems and hardware platforms listed below.

The table lists the versions of Fiery products that are compatible with macOS 13 Ventura running on Intel CPUs.

EFI is actively working to optimize its products to run natively on Apple computers using the Apple M1/M2 chip. See below for Fiery products that currently run on Apple M1/M2 computers using the macOS 13 Ventura Rosetta2 dynamic binary translator. 

Fiery Software Compatibility on Intel CPU

Compatibility on Apple M1/M2 with Rosetta2

Compatibility on Apple M1/M2 (native, without Rosetta2)

Fiery Command WorkStation Package
 - Fiery Hot Folders
 - Fiery Impose, Compose, JobMaster

6.8.0.277
6.8.0.277
6.8.0.277
Some components of version 6.8 continue to use Rosetta2
Fiery Driver
Fiery Driver 7.0
Please see EFI Communities for updates

Not applicable

Fiery Driver 7.0
Please see EFI Communities for updates
Fiery FreeForm Create 1.3  1.3 Not compatible yet
Fiery Color Profiler Suite 5.4.3.12 5.4.3.12 Version 5.5*
* Targeted for early December 2022
Fiery XF Universal Driver 7.3.2.07 7.3.2.07 7.3.2.07
Fiery proServer and Fiery XF      
  - Fiery XF Server (Windows only server) Not applicable Not applicable Not applicable
 -  Fiery Color Profiler Suite 5.4.3.12 5.4.3.12 Version 5.5*
* Targeted for early December 2022
 -  Fiery Command WorkStation Targeted for early December 2022 release
Targeted for early December 2022 release
Targeted for early December 2022 release
Fiery Prep-it      
  - Fiery Prep-it Server (Windows only server) Not applicable Not applicable Not applicable
 -  Fiery Prep-it Client Targeted for mid November 2022 release Targeted for mid November 2022 release Targeted for mid November 2022 release
 Acrobat 2017 Enfocus PitStop 2019 kit Compatible  Compatible  Not compatible. May experience licensing issue. 
 Acrobat 2020 Pro Package Compatible Compatible Compatible
PrintMe
Includes PrintMe Mac driver, PrintMe Web Release, and PrintMe.com website 
Compatible Compatible Compatible (except PrintMe Mac driver which requires Rosetta2)
 EFI IQ      
 - ColorGuard
   Including ColorGuard Desktop and
   colorguard.efi.com 
 Compatible Compatible EFI ColorGuard 1.6*
* Targeted for first half of 2023
 - Dashboard, Insight, Manage, Notify  Compatible Compatible Compatible 
 - EFI Cloud Connector  Compatible Compatible Not compatible yet
 Self-Serve AdminCentral  Compatible Compatible  Compatible
 Fiery JobFlow  2.8  2.8 2.8