Fiery VUE 1.5.J Download

Fiery_VUE_Main 


Fiery VUE 1.5.J can be installed on 32-bit or 64-bit Windows operating systems.

If you are running a 64-bit Windows operating system, you are strongly encouraged to install Fiery VUE 
2.x. Going forward, all new features and additional certified servers will be only available on VUE 2.x. 
How do I find my operating system version?

See complete VUE specifications

Back to Fiery VUE page